Two week ride with mixed results



  • Hello all,
    I've had the planner and Nav app for about 2 years now I guess. It's been a heck of a learning experience for sure. Just got back from a two week vacation riding up to South Dakota, Wyoming from Texas and had some mixed results. Some of it may just be me, but I put a lot of hours into using the planner app along with google maps to compare gas stations, hotels, etc. Forget the whole load the MRA Planner gpx file into the Harley GPS system because it will continuously try to reroute me, not MRA's fault but I thought I could use that as a back up, that just turns out to be a nightmare.

    On my trip I found for plotting from Dallas to Kolby KS then to Spearfish SD next day. I don't have the specifics in front of me now but MRA showed one day using the same exact route like 2 hours longer than Google Maps, for the same exact route, I thought that very odd.

    Anyway, I used my routes a couple days and ran into some issues, I have a 2020 Harley Road Glide Limited, which does have Android Auto, which I connect to with a cable to my phone. As we were on day 3 with some very specific roads I wanted to be on, NAV was rerouting me different than the Nav my girlfriend was using on her phone, which was the maps I created on MRA Planner and shared with her. The only thing I could conclude was I had MRA Nav running but plugged into my bike with Android Auto, I think Waze is the closest app running and trying to recognize it on the bike, and it was over riding possibly my NAV app and trying to send me the quickest route. It was a disaster. That night I had to uninstall Waze off my phone to see if that would help.

    The next day I had a few times where going down the road, I would back out of MRA Nav to my gopro software to start recording video, then come back into NAV, and next thing I know it's telling me to do a U turn at the next stop and basically send me back to waypoint 1. I've run this software long enough now to know that something isn't right and then I go into skip waypoints from 1 to where I currently am like wp28.

    Maybe it's just me, but I honestly feel like I almost need to go back to just writing down the turns on notecards because every time I put a trip together I struggled bad with this app. I gotta put like 50 waypoints down just to keep it on the exact road I want on a long trip otherwise it wants to send me some dirt road to get to the next section I called out for. Going out of the app to Sirius XM to set up some music, I come back, it's rerouting me to waypoint 1, I even selected the skip waypoints automatically beta section to see if that would help. Nope.

    I thought well maybe if they integrate Android Auto into this app that would resolve some issues, but doesn't look like that is happening anytime soon with car play still being worked on.

    Like I say, I want to love this app, but I put in several weeks of hours of plotting these roads and trips to find one trip after another I am leading people into U turns, dirt roads or some other embarrassing situation. Part of it may be I don't do these trips or use this every single day, but damnit it really shouldn't be this difficult or frustrating to ride a selected route, and at the end of the day have to have my gf looking at a paper map telling me no, do not turn here, even though NAV says turn, stay on this road.


  • Instructor

    @Russ-1
    hello Russ,

    Sorry to hear you've had so many issues using the Navigation app.
    It is difficult to indicate from behind the PC exactly where it comes from.
    Is it due to the routes taken?
    Does it depend on whether you turn off your phone during a break?
    Did you accidentally not close the app when you opened another app?
    Which version did you use and on which phone?



  • @Russ-1

    Hi Russ,

    I used MRA Navigation recently for a particular Route I was doing for a YouTube video.
    Basically, it meant going across every bridge on the River Rother (West Sussex UK) and taking photos of every bridge.
    I used MRA Nav because I had made each bridge a Red Waypoint as there are also quite a few bridges on the route that are tributaries not part of the River Rother.

    Anyway to get to the point, each time I came to a bridge I took the phone out of it handlebar case and used the pause button in MRA Navigation. I then sent MRA Nav to the background and opened my camera app on the phone and took photos of the bridges.
    Then putting MRA Navigation in focus again I just tap the screen and it lets me continue on with no issues.
    This worked for me on all 19 bridges.
    My phone is Samsung S10 5G all the latest updates etc.



  • @Hans-van-de-Ven-MRA-Master
    Hi Hans, and Steve,
    I don't turn off the phone generally on any of my trips. I will plan a route for Day1 CrazyHse to Mt.Rushmore. If I am riding along during my ride using Nav, then I want to open my Sirius XM app to play some music or go into my GoPro app to start recording video, I just back out to my home screen, I don't pause or close the app out, I figure it should just continue running in background until I come back into it. Keep in mind I'm doing this while going down the road, so I don't stop on the side of the road to turn GoPro on or start music in my Sirius Xm app. I also download the offline state maps and then select offline when I start the trip because I've been burnt on that one too where you get so remote that you lose internet and then it updates when internet comes back and reroutes you because it thinks you've missed a waypoint. I have a samsung galaxy s20 which is very much updated and my Nav app is 1.6.7 so should be the latest too.
    This first map I think after I left 2, I had went into my Sirius XM app and then came back into NAV and it started trying to get me to white squiggly line route 87 to Mt. Rushmore instead of my planned waypoints the black line, because it was the shorter route.
    I just assume this is because I have waze on my phone (which I was not using) and connected to my bike with Android Auto, and it thought this app must be waze???? No idea but it was rerouting me.
    That night is when I uninstalled waze off my phone so if that was the case it would not do that again.

    6c09b522-512d-4009-b239-67edfcc8454d-image.png

    The last day I created a ride with some 70 waypoints so it would not jack me up and send me down some dirt road, which to me is ridiculous, I should not need to put that many waypoints on a ride. Well that was actually working out just fine, but it was this day that I backed out of the Nav app, to home screen then went to GoPro to fire up the video, was on that for about 30 minutes then went back into the Nav app, and I had figured it must surely update from where I was, 30 minutes ago, I had been on the same section of road albeit passed over 5 or 6 waypoints in that time frame and just continue on from there but no, it had me doing a U turn, and when I went to skip waypoints, of which I should of been on like 38 at this point I figured it would ask to skip from like 33-38 or something but it was starting from 1 to skip, which I was mashing skip skip skip from 1 to 38 going down the road. To me that's not feasible.

    ec135a53-71a0-4722-ba5f-a38125667e1d-image.png


Log in to reply
 

Ambassadors
Want to participate in the MyRoute-app community, get recognized and grab cool rewards? Perhaps you'd like to become a MRA Ambassador.
ACTIVE USERS
POPULAR TOPICS MY GROUPS