Zumo XT navigation issues



  • I have a route that starts not far from home and ends at my home. The first route point is a via point, as is the last at my home. The rest are shaping points as that is how MRA makes them.

    The problem is, after I pass the first via point, it eliminates all the 6 shaping points and routes me directly back home. I've tried it with recalculation on, that makes all the shaping points disappear. I turned recalculation off and the rest of the route remains as a purple line, but all the directions given try to get me right back to home. The former is displayed in the Youtube video. Why does this happen and how can I avoid it?

    https://www.youtube.com/watch?v=f-refhmPtaQ

    Thanks



  • @Chris-Smith

    As you are travelling to the first Via Point maybe the Garmin XT is expecting you to temporarily stop at that first Via point.

    It is also worth indicating how you are transferring the GPX file to the XT from MRA.
    The XT needs to use the GPX1.1 (BETA, Route, Track, POI) to correctly use Via and Shaping Points.
    It could also be that the first Via Point and the Destination Via point are too close together, as I’m sure I’ve seen that mentioned in the Forum.
    It’s probably worth making your Route Public so others members can see it in MRA.


  • Instructor

    @Chris-Smith
    Chris, when you create a route in MRA, the 1st and last point are always a viapoint.
    Attached route put together by just placing the points.
    The 1st and last will automatically become a via point.
    And as Steve indicates, use the correct gpx file: GPX1.1 (BETA, Route, Track, POI) or if you use the connector: Garmin Zumo XT (gpx 1.1)

    ff3d0768-686b-46cc-8246-a61837faf805-image.png



  • @Steve-Lynch Here is the route
    https://www.myrouteapp.com/route/open/5132341

    Note the name is: WC_2.11_Copy_BETAGPX11_LoopY
    Ignore "WC_2.11_", that's just a naming scheme
    "Copy_BETAGPX11_LoopY" indicates it was a "save as BETAGPX11" then manually copied to the GPS. Then when I power on the GPS, it finds new routes and I convert them to trips. LoopY means I am trying to run a route that starts at a motel and ends at that same motel. In this instance, it's a short 10 mile loop starting and ending at my home.

    All this effort is just to understand how to make the XT function on a loop route as above using a GPX 1.1 format, leveraging via points and shaping points. My 10 year old ZUmo 220 just died, 20 trips over 3000 miles on that one. It was always GPX 1.0 (all waypoints are via points). Now I have the XT and so far, I'm struggling.

    Here is a similar loop route but on a real trip, it's to 5 national parks in Utah, 3600 miles, so I need to get this thing figured out. This trip is in 3 weeks.

    https://www.myrouteapp.com/route/open/5042370



  • @Hans-van-de-Ven-MRA-Master
    Yes, the MRA makes the first and last via points, everything in a middle is a shaping point. it happens automatically, you have to change points in the middle to via points manually if you needed that.

    If you look at my Youtube video and pause it at 1:00, you can see my entire route, 1 via point to start, 6 shaping points and a via point/checkered flag at my house to complete the trip. Then it hits the first via point and recalculates the entire trip, bypassing all the shaping points and taking me straight home. I could do GPX 1.0 and go the way I want, but via points are a pain when you miss them.

    I have the latest software and maps.
    Attached is a screenshot of an XLS of every permutation I have tried. I actually test software for a living. Every single record is one change only, then run the test to see if it works.

    I'll run any test any way you want. I think the issue could be my first via point is too close to my end via point. I have another file made to test but it's 96F out right now. I will run it first thing in the morning (8am CST) and report back.
    Thanks

    Image of test plan



  • @Chris-Smith

    You are effectively starting your Route from “Home” which is also the final Destination Via Point as it shows in your video..
    The obvious solution would be to amend waypoints 1 and 8 as below.
    I’m not going to offer a cause for your issue however as I am still working out the niggles on the XT myself.
    One other thing to mention, are you using the Here Map when creating your routes in MRA?

    Screenshot 2021-08-29 at 09.33.58.png



  • That's not the final map. That one didn't work, so I moved the first via point along, and moved # to my actual house. It had issues also due to me not precisely placing the first via point and also me NOT using the HERE maps. So overall, a cluster.

    https://www.youtube.com/watch?v=f-refhmPtaQ

    After some analysis from others on ADVRider, I came up with the following lessons learned and applied them, then the route worked fine.

    1. Use the HERE maps when exporting.
    2. Be precise when placing via points
    3. Put my first via point in a loop route far from home/motel on a loop route.

    Here is that thread. I have learned a LOT, thanks to input from many such as yourself, so thanks to all that contributed.

    https://advrider.com/f/threads/zumo-xt-vs-myrouteapp-circular-route-goes-straight-to-end.1516701/

    If you'd like to add to my lessons learned list, I'm all ears.


Log in to reply
 

Ambassadors
Want to participate in the MyRoute-app community, get recognized and grab cool rewards? Perhaps you'd like to become a MRA Ambassador.
ACTIVE USERS
POPULAR TOPICS MY GROUPS